Brothers GPA Calculator - API Cascading Failure – Incident details

Brothers GPA Calculator experiencing major outage

API Cascading Failure

Resolved
Major outage
Started almost 3 years agoLasted about 1 hour

Affected

Brothers GPA Calculator

Major outage from 3:30 PM to 4:33 PM

Brothers GPA Calculator Development Build

Major outage from 3:30 PM to 4:33 PM

Brothers GPA Calculator API

Major outage from 3:30 PM to 4:33 PM

Updates
  • Resolved
    Resolved

    Our fixes have been deployed and all services have returned to normal.

  • Monitoring
    Monitoring

    A fix has been pushed to our server hosts, and the issue seems to be resolving. We will continue to monitor the situation and insure that the problem does not restart.

  • Update
    Update

    The critical API error appears to be a complete outage on our KCXConnect server. We are currently trying to identify the direct cause and release a temporary fix. At this time, the following services are effected: The GPA Calculator, Analytics Services, Account Services, Data Saving, API Test Systems + more.

  • Investigating
    Investigating

    Our analytics, account, and general data API's are currently experiencing a critical API outage. We are currently investigating the cause of the outage.