Brothers GPA Calculator - Server Host Cascading Failure – Incident details

Brothers GPA Calculator experiencing major outage

Server Host Cascading Failure

Resolved
Major outage
Started almost 3 years agoLasted about 21 hours

Affected

Brothers GPA Calculator

Major outage from 7:18 PM to 4:46 PM

Brothers GPA Calculator Development Build

Major outage from 7:18 PM to 4:46 PM

Updates
  • Resolved
    Resolved

    The server hosting issue has been resolved and all services have returned to normal!

  • Monitoring
    Monitoring

    The server host has implemented a fix, and services are returning to operation. We will monitor the situatoin until all services have returned to normal.

  • Investigating
    Investigating

    One of our server hosting services is currently experiencing a cascading hosting failure. This has left several of our backend services unavailable or inoperable. The effected services include, but are not limited to, analytics, data storage, and connected services.

    This outage has caused the following KCX Systems to go offline: KCXConnect, KCXSecure, KCXGlobal