Brothers GPA Calculator - Sustained DDoS Attack – Incident details

Brothers GPA Calculator experiencing major outage

Sustained DDoS Attack

Resolved
Partial outage
Started almost 3 years agoLasted 1 day

Affected

Brothers GPA Calculator

Partial outage from 5:30 PM to 7:30 PM

Brothers GPA Calculator Development Build

Partial outage from 5:30 PM to 7:30 PM

Updates
  • Resolved
    Resolved

    The DDoS Attack has been mitigated, and all malicious traffic has stopped.

  • Monitoring
    Monitoring

    A combination of Cloudflare and KCXSecure DDoS mitigation systems have successfully blocked 100% of malicious traffic. We will continue to monitor the situation to ensure that the attack has been completely stopped.

  • Identified
    Identified

    We are currently using DDoS mitigation systems to block a Layer 7 Distributed Denial of Service Attack. The sending unit has not been identified, and the DDoS attack is targeting the production level servers. Traffic is being routed through Cloudflare and KCXSecure for DDoS mitigation.

  • Investigating
    Investigating

    We are currently using DDoS mitigation systems to block a Layer 7 Distributed Denial of Service Attack. The sending unit has not been identified, and the DDoS attack is targeting the production level servers. Traffic is being routed through Cloudflare and KCXSecure for DDoS mitigation.